Back
Maintenance

Billing Portal Upgrade

Completed 21 Mar at 01:49pm GMT.

AllHost Billing Panel
Completed

Maintenance completed

Posted 21 Mar at 01:49pm GMT.
Started

We are currently undergoing billing control panel upgrade. Your services will not be affected by this change. Please contact support@allhost.io if you have any urgent queries.

Posted 21 Mar at 12:49pm GMT.